Sync delays on Mentor

Incident Report for DataMesh Group

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 10:34 AEST

Investigating

Dear valued clients,

Mentor data is currently delayed up to 1 hour. The appropriate teams are acting on the issue as a priority. We are expecting data to synchronize and return to normal in due time.
Posted Apr 02, 2026 - 15:21 AEDT
This incident affected: Merchant Portal (Mentor) (Merchant Website, Data API).